El día de la marmota IPv6

Hoy día 8 de junio de 2011 es el “IPv6 day!”: los grandes jugadores en Internet quieren dar visibilidad a la nueva versión del protocolo que rige el funcionamiento de la red de redes (IP) y demostrar que es seguro dar el paso a IPv6. Puede hacerse una analogía con el día de la marmota, en que un simpático animalito anuncia si ha llegado el final del invierno (o de la IPv4, en este caso).

Desde primeros de febrero de este mismo año, las últimas direcciones IPv4 fueron asignadas por IANA con lo que el crecimiento de la red ha llegado a su techo. Es por ello que empresas como CISCO, AT&T, Facebook, Google y Yahoo entre otras mueven ficha para dar visibilidad a las nuevas posibilidades que nos ofrece el protocolo IPv6.

He tenido el placer de participar en la organización y configuración de una de las actividades programadas para este día. La actividad consistía en desplegar una red de sensores con conectividad 6LowPan y UDP y a través de un tunel IPv6 “twittear” su información en Pachube también a traves de un enlace IPv6. Esta actividad pretende demostrar que la”Internet de las Cosas“es una realidad gracias a 6LowPan y IPv6.

Hace 2 meses me hice con un router Cisco Catalyst 2800 que he configurado para crear un Tunel IPv6 sobre un enlace IPv4. Mi tunel unía la red de sensores desplegada en Barcelona con el backbone de AT&T. Desde allí, otro tunel unía AT&T con el servidor de Pachube. Desde ayer, la red esta funcionando con normalidad, como podéis ver aquí. Os dejo aquí la configuración del router y el enlace a la noticia publicada por CISCO.

IPv6 Tunneling

IPv6 Tunneling

Para los no entendidos una dirección IPv6 tiene el aspecto siguiente:

2001:0db8:85a3:0000:0000:8a2e:0370:7334/64

Son 128 bits que, expresados en hexadecimal, se representen como 32 cuartetos,  es decir, cada dígito representa 4 bits de la dirección. El prefijo /64 indica que los primeros 64 bits son de dirección de red mientras que los 64 restantes son para direccionar hosts. De la misma manera, la máscara IPv4 diferencia los bits de red de los bits de host, el prefijo nos indica los bits de red, así que contra más grande el valor del prefijo menos direcciones tenemos en nuestra red.

Aquí tenéis la configuración del router:

interface Tunnel1
description Primary tunnel to AT&T IPV6 gateway
ip unnumbered GigabitEthernet0/0
ipv6 address IPv6 MYSIDE OF THE TUNNEL
ipv6 enable
tunnel source my IPv4 address
tunnel mode ipv6ip
tunnel destination the IPv4 end point of the tunnel
!
interface Tunnel2
description Backup Tunnel
ip unnumbered GigabitEthernet0/0
ipv6 address IPv6 MYSIDE OF THE TUNNEL (alternative)
ipv6 enable
tunnel source my IPv4 address
tunnel mode ipv6ip
tunnel destination the IPv4 alternative end point of the tunnel
!
interface GigabitEthernet0/0
description Internet facing interface IPv4
ip address the IPv4 external IP + netmask
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
description ipv6 interface
no ip address
duplex auto
speed auto
ipv6 address MY LAN IPv6 LAN interface address.
no cdp enable
!
router bgp 2386
bgp log-neighbor-changes
neighbor IPv6 Other side of the tunnel remote-as AS Number
neighbor  IPv6 backup side of the tunnel remote-as AS Number
!
address-family ipv4
neighbor IPv6 Other side of the tunnel activate
neighbor IPv6 Other side of the tunnel activate
no auto-summary
exit-address-family
!
address-family ipv6
network LAN IPv6 network address
neighbor IPv6 Other side of the tunnel activate
neighbor IPv6 backup side of the tunnel activate
exit-address-family
!
ip default-gateway MY IPv4 default gateway
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 MY IPv4 default gateway
!
ipv6 route NETWORK IPv6 address Null0

Xavier Vilajosana es profesor de los Estudios de Informática, Multimedia y Telecomunicación de la UOC. Es Doctor en Ciencia de la Computación y Ingeniero en Informática. Su area de conocimiento son las redes de computadoras, los sistemas distribuidos y, como nexo entre ambos, las redes de sensores.

3 Comments

  1. Buenas Xavier,
    En primer lugar quería decir que tu artículo me ha parecido perfecto y es una gran ayuda. Yo nunca he aplicado este tipo de túneles, pero en las certificaciones que tengo me he tenido que estudiar varios tipos. Como veo que eres un experto en la materia, hay un tunel que es de ipv6 a ipv6, pero nunca he leído ningún artículo ni lo he visto configurado en ninguna empresa. actualmente, ¿éste tipo de túneles se utilizan?, lo digo porque si encapsulas ipv6 baja ipv4 vuelves a tener el problema del direccionamiento que se agota y los problemas de seguridad que implica el protocolo ipv4.

    Gracias Xavier
    Salu2
    Dani

    Reply
    • Gracias Dani por tu comentario,

      En este caso, el tunel IPv6 sobre un enlace IPv4 se ha realizado porque no havia conectividad IPv6 entre nuestra red y la red donde estavan los servidores de Pachube. Por ese motivo tuvimos que encapsular nuestro enlace en un tunel que nos “virtualizaba” la conexión de manera que podiamos vernos como si estuvieramos en la misma red (a parte claro de querer utilizar IPv6). En un caso hipotético en el que tuvieramos plena conectividad IPv6, los tuneles solo servirian para crear redes privadas sobre enlaces abiertos, en ese caso, seria algo mas orientado a la seguridad de la comunicacion que no a la posibilidad de comunicarse como ha sucedido en el caso aquí presentado.

      En respuesta a tu pregunta. Como hoy en dia hay pocas redes IPv6 publicas (enlaces troncales) el tunel no es necesario ya que normalmente se utilizan dentro del ámbito de una misma empresa o institucion. Esta claro que los tuneles sobre IPv4 no solucionan nada pero hasta que la infraestructura de redes troncales no soporte IPv6 es la unica manera de llegar donde una quiere.

      La configuracion seria parecida pero los extremos de los tuneles serian tambien direcciones IPv6.

      Veremos lo que pasa en un futuro.
      Un saludo.
      Xavi

      Reply
  2. Me resulta muy útil este apunte. Por lo que veo es casi como configurar un tunel GRE donde en vez de montar IPSEC se monta el protocolo IPv6.

    Un saludo

    Reply

Comentar

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Leer entrada anterior
¿Cómo traducir “Ingeniería Informática” al inglés?

Todos hemos pasado por este momento: estamos escribiendo nuestro currículum en inglés o rellenando el perfil en LinkedIn y llegamos...

Cerrar